This guide covers upgrading a 3.4 Spree store, to a 3.5 store.

Update Gemfile

gem 'spree', '~> 3.5.0'
gem 'spree_auth_devise', '~> 3.3'
gem 'spree_gateway', '~> 3.3'

Run bundle update

Install missing migrations

rails spree:install:migrations
rails spree_auth:install:migrations
rails spree_gateway:install:migrations

Run migrations

rails db:migrate

Install Spree Analytics Trackers extension

If you were previously using Analytics Trackers feature you need to install it as an extension as it was extracted from the core.

  1. Add Spree Analytics Trackers to your Gemfile:

ruby gem 'spree_analytics_trackers', github: 'spree-contrib/spree_analytics_trackers'

  1. Install the gem using Bundler:

bash bundle install

  1. Copy and run migrations:

bash bundle exec rails g spree_analytics_trackers:install

You’re good to go!

Read the release notes

For information about changes contained within this release, please read the 3.5.0 Release Notes.

Verify that everything is OK

Run you test suite, click around in your store and make sure it’s performing as normal. Fix any deprecation warnings you see.